
Single Crystal X-Ray Crystallography1,2 

You will use the program SHELXTL to unravel the structure of an organic compound (to be 
referred to as Ylid) from the data supplied by our x-ray diffractometer. The data, in the file 
ylid.hkl, consist of the x-ray intensities observed for reflections from many planes, identified by 
three index numbers, h, k, and l. The diffractometer automatically orients the crystal and the 
detector to pick up reflections from each plane, and records the number of counts per second as 
the intensity.  

The empirical formula of Ylid is C11H10O2S. Before you start, you should use MOE (or distance 
geometry and MM2) to construct several small molecules to give you an idea of what bond 
lengths to expect for C-C, C-O, C-S, O-S, C-H, O-H, and S-H single and (where feasible) double 
bonds, because you will have to try to recognize them. Try to get an idea of the variability of the 
bond lengths by building different environments. 

There are four main programs in the SHELXTL suite. XPREP helps you make an initial decision 
about the space group and sets up the files to be used by the other programs. XS tries to find the 
positions of atoms directly from the x-ray diffraction data without using Patterson maps. XS will 
probably find more atoms than there actually are, and it may identify only a few of them. The 
atom positions of the real atoms it finds will most likely be dsiplaced from the true positions. 
XSHELL allows you to visualize the structure at any point in the analysis. It allows you to 
determine distances and angles between atoms, to rename provisional atoms to real atoms, and to 
delete bad atoms from the list. XSHELL or XLS refines the structure, trying to find the best fit to 
the intensity data. 

XPREP  

From the Start menu and the BrukerAXS Programs group run SHELXTL. Pull down the project 
menu and choose New. Type in the project name: ylid. Under "Look in:" go to the directory 
D:\xray\ylid, and click on ylid.p4p. Set D:\Xray\ylid\ylid.* as the project path and click Open. 
SHELXTL returns to the main menu. Click on XPREP in the top menu bar.  

Next you will be shown some information about lattice exceptions in order to choose the type of 
crystal lattice. The lattice types correspond to the positions of lattice points, repeating elements 
centered on some defined position in the unit cell. The simplest lattice (P, for primitive) has 
lattice points only on the corners. If the center is also a lattice point, it is designated I (body-
centered cubic). If two opposite faces are lattice points, the designation is A if they are along the 
x-axis, B if the y-axis, and C if the z-axis. F designates a face-centered cubic lattice in which all 
faces are occupied. The abbreviations Rev and Obv (reverse and obverse) in XPREP refer to 
hexagonal unit cells, which we will not have to worry about. The type of lattice determines 
which planes should not yield any reflected intensity. Lattice exceptions are reflections that 
occurred anyway. For the correct lattice that number should be small. It must be zero for 
primitive lattices, since there are no exceptions. Allow the computer to choose the correct lattice 
for you by pressing Enter to accept the default choice.  



You must next choose a crystal system (select H on the menu). The seven crystal systems are 
triclinic, monoclinic, orthorhombic, tetragonal, rhombohedral, hexagonal, and cubic. 
Rhombohedral and hexagonal systems are associated with hexagonal unit cells. You will be 
offered several possibilities. The default cell is triclinic (a≠ b≠ c, α ≠ β ≠ γ ), but it looks for 
possibilities with higher symmetry. Note how many possible cells you have. Let the program 
choose, but keep track of which lattice type and which crystal system you have chosen, because 
you will get asked again. You may go through XPREP again if you wish to try a different crystal 
system.  

Let the program guide you through the remainder of the setup, including the space group 
assignment. For more on space groups, see Atkins. Note the number of molecules per unit cell, 
Z, and the unit cell volume, which should be near 18. If you go back through XPREP later and 
make different decisions you can choose a new name and work along two or more lines at once. 
XPREP writes an instruction file for XS (called name.ins, where name is the name you chose), 
and a set of intensities, possibly recalculated to fit the new crystal group and space group. 

XS  

This program runs virtually autonomously. Just click on XS in the top menu bar. There are many 
modifications one can make to XS, but it often works quite well without any. XS writes a 
name.lst file, which lists some information on the process, and a name.res file, which contains 
the results. The results file is read by XSHELL. 

XSHELL  

This is a powerful program to view the atoms in the positions found by XS. To start, click on 
XSHELL in the top menu bar. Most of the atoms are provisional, designated as Q1, Q2, etc. 
Your job will be to figure out which of them is a carbon, oxygen, sulfur. Hydrogen has such a 
small electron density that it is hard to locate, especially at the beginning of the process. There is 
a way to fill them in later in ideal calculated positions. If you are unsure if a given peak is in a 
correct position, the best approach is to delete it. If enough of the correct structure is included in 
the model, your next refinement of the structure will produce a better model that is easier to 
interpret. 

You can display the atom list in compact form by pulling down the Atoms menu and choosing 
Info on All. Remember, that you have 14 heavy atoms. Scan down the atom list to see the 14 
largest peak heights, so that you have a point of comparison. Real atoms tend to have larger peak 
heights. Atom coordinates are given as fractional coordinates relative to the unit cell dimensions 
a, b, and c. The atoms have colors, which are specified by the atom type in the info list. To start 
with, all or most all of your colors will be yellow, signifying provisional atoms. Orient the 
molecule by dragging with the left mouse button. As you move the mouse over possible atoms 
peak heights will be displayed in the upper left hand corner of the screen. 

You will want to compare bond lengths and angles with those expected for sp3 and sp2 carbon, 
oxygen, and sulfur. To do this, position the mouse over a particular "bond." The bond length will 
appear in the upper left hand corner of the display. To determine the bond angles to a particular 



atom, place the cursor over the central atom, click right and choose Bonds and Angles. For 
example, for Q3: 

 

The bond angle Q1-Q3-Q5 is 119.07° and the 
Q3-Q5 bond length is 1.564Å. Q8-Q3-Q5 is 
107.06°. You may want to choose the atom to 
start with by picking some region of the 
molecule that looks like something reasonable. 
Such regions might be five or six membered 
rings or recognizable functional groups. 

Assume you have selected Q1 from which to start tracing the molecule. Check the distances 
between Q1 and its neighbors. Suppose that Q1 is shown "bonded" to Q27. However, the bond 
length to Q27 may be too short for a reasonable bond. If everything still makes sense with Q27 
out of the picture, then delete Q27. Deleting a false atom is done by placing the cursor over the 
suspect atom and pressing "K".  

Note: If you mistakenly delete a peak, you can restore it with the Restore Killed Atoms 
feature. Deleted atoms (including Q peaks) go into a list. You can restore any atom in this 
list (and should probably do so immediately) by choosing Edit > Restore Killed Atom(s). 
The Undelete Atom(s) panel appears. Those atoms deleted last are at the top of the Deleted 
Atoms List. Highlight each atom you wish to restore, and click on the Restore button. 

When you have a good guess for an atom, rename it. For example, if you would like Q1 to be 
oxygen, you might name it O1. To name an atom, first select it by placing the cursor over the 
atom and pressing the "S" key. The labels of selected atoms turn blue. Pull down the Select 
menu, slide right on Atoms, and choose Edit. In the Type dialog box enter the atom type, e.g. 
"O" or "C". If you know the atom hybridization, you can also enter it, as shown below. 

 

To deselect an atom, just place the cursor over the atom and press the "S" key again. 
Alternatively, you can pull down the Select menu and choose Deselect All. Another way to 



rename and delete that is especially good when you have a whole bunch of the same element to 
do is to use the Labels > Group Labels command. For example, select Q atoms in the six 
membered ring. The labels of these selected atoms turn blue. Pull down the Labels menu and 
choose Group Labels. If not already shown type "C" in the label box, as shown below. The initial 
Number of 1 is fine for this example. In general it is best not to have two atoms with the same 
label so choose the initial number to avoid duplicate atom labels. Try to choose a numbering 
system that makes sense for the molecule as it is developing. 
 

You have 11 carbon atoms, two oxygen atoms, 
and one sulfur atom to assign. It is not 
necessary to decide on all of them, but you 
should go through the provisional atom list and 
either rename or kill each atom. It is all right to 
finish this stage without all 14 atoms defined. 
Once you have pared down your list, XSHELL 
will prepare the instruction file for the next 
step. 

 
Refining the Model:  The next step is to refine your structure and look for missing atoms. 
XSHELL runs the XLS program, which will go through a least squares program to fit calculated 
x-ray intensities to the experimental intensities, varying atom positions to try to get the best fit. 
(XLS writes a name.res file that can again be used for further editing). The program also supplies 
a new list of provisional atoms, which you will have to dispose of one way or another. To begin 
click on the Refine menu. Change the value of Plan to 10 atoms. Plan is the maximum number of 
new provisional atoms that will be generated. Choosing a smaller number than the default value 
will decrease the number of Q atoms that you will need to delete. Set Fourier: to Difference Map; 
in doing so Q peaks will be generated from a Difference electron density map calculated after the 
fourth least squares cycle. 

 



During its refinement, XLS is trying to reduce the R-value, similar to the R correlation 
coefficient you have used for plotting straight lines. For a good solution, R should be somewhere 
around 0.05. If you can get under 0.10 it can be taken to indicate that you have the correct 
structure. As the refinement proceeds the progress will be printed to the screen: 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 
+  XL  - CRYSTAL STRUCTURE REFINEMENT - SHELXTL Ver. 6.12 W95/98/NT/2000/ME   
+  Copyright(c) 2001 Bruker Analytical X-ray Solutions  All Rights Reserved   
+  ylid                                  started at 10:06:49 on 10-Apr-2003   
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 
 
Read instructions and data 
Data:    2293 unique,      0 suppressed   R(int) = 0.0167   R(sigma) = 0.0209 
Systematic absence violations:    6    Bad equivalents:    0 
wR2 =  0.6066 before cycle   1 for   2293 data and    57 /    57 parameters 
GooF = S =     6.593;     Restrained GooF =      6.593  for      0 restraints 
Mean shift/esd =   1.818    Maximum =  -9.289 for  U11 S1         at 10:06:50 
Max. shift = 0.045 A for C4      Max. dU = 0.021 for C11                      
wR2 =  0.5229 before cycle   2 for   2293 data and    57 /    57 parameters 
GooF = S =     5.272;     Restrained GooF =      5.272  for      0 restraints 
Mean shift/esd =   1.053    Maximum =  10.663 for  U11 C11        at 10:06:50 
Max. shift = 0.036 A for C11      Max. dU = 0.037 for C11                     
wR2 =  0.4658 before cycle   5 for   2293 data and     2 /    57 parameters 
GooF = S =     4.490;     Restrained GooF =      4.490  for      0 restraints 
R1 =  0.1638 for   2239 Fo > 4sig(Fo)  and  0.1658 for all   2293 data 
wR2 =  0.4658,  GooF = S =   4.490,  Restrained GooF =    4.490  for all data 
R1 =  0.1770 for   1380 unique reflections after merging for Fourier 
Highest peak    5.06  at  0.8303  0.1216  0.2298  [  1.80 A from S1 ] 
Deepest hole   -1.05  at  0.9425  0.7016  0.1974  [  0.12 A from C11 ] 
 
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 
+  ylid              finished at 10:06:51   Total CPU time:       1.2 secs  + 
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 
 
After the fourth cycle of least squares, the goodness of fit (GOOF) is 4.49 and the R1 value for 
all 1380 reflections is equal to 0.1770. Sometimes, you might get a message in the printout that 
says: 
 
 ** Absolute structure probably wrong - invert and repeat refinement ** 
 
If so you should check the Invert check box in the Refinement Control the next time you do a 
refinement. 
 
Look through the new Q peaks and decide which are real atoms and which are false atoms. 
Rename or kill all of the new Q peaks. You can delete all the remaining Q peaks by pulling down 
the Edit menu and choosing Kill All Q-Peaks. You can repeat the refinement process as many 
times as you like. 
 
When you have the skeleton (C11O2S) figured out, you should add hydrogens pulling down the 
Atoms menu and choosing Hybridize All. Atoms colored yellow have s-type hybridization, 
atoms colored red have sp-type hybridization (none shown), atoms colored pink have sp2-type 
hybridization, atoms colored cyan have sp3-type hybridization, and atoms colored gray have no 



assigned hybridization type. It will be very important whether a particular atom is sp2 or sp3. If 
the automatic calculation gives the incorrect hybridization, you can change the hybridization 
using the Select > Atoms > Edit… dialog. Add hydrogens by pulling down the Atoms menu 
again and choosing Calculate Hydrogens. You must check that each carbon has the correct 
number of hydrogens, depending on the number of available bonding sites. If the incorrect 
number of hydrogens is assigned, check the hybridization of the attached atom. 
 
Final Refinement:  All atoms have now been located and labeled. So you can now refine all 
atomic parameters, including the anisotropic atomic displacement (or temperature) parameters. 
The temperature factors are a measure of how much the atom moves as the molecule vibrates. 
This process generates "thermal ellipsoids" that show graphically the extent of the motion of the 
atom. The bigger the thermal ellipsoid the greater the motion. Therefore, this time make sure to 
set the Aniso and Acta checkboxes. You can also set Plan to a smaller number, since all atoms 
should now be located. Also enter a 0.0001 in the Extinction box so that this parameter will be 
optimized. (This specific crystal is spherical so the Extinction should optimize to zero, but in 
general use the Extinction will be non-zero). Choose Invert if previous runs suggest doing so. 
 

 
 
The final R1 value should now be much smaller than before. You should be able to get a value 
less than 0.05. Click right on the background and choose Thermal Ellipsoid. If any of the thermal 
ellipsoids are unusually small or large, you may have assigned the atom type incorrectly. If you 
change an atom type, adjust the number of attached hydrogens and refine again. If you get a 
better R1, you have made a better choice of atom assignments. 
 
To print your structure, first do a print "preview" by pulling down the Render menu, slide right 
on Color, and choose To Screen... After the molecule is rendered press the space bar. To actually 
print the structure, repeat the process, except this time select To High-Quality JPEG… In the 
Bitmap Preferences Dialog leaving most of the directory path, type in a name for your file 
ending in .jpg; for example D:\XRay\pretty.jpg. Click OK. Once you quit ShelXTL, navigate to 
your file (in this example it will be on the D: drive in the XRay folder) and double click. The 

0.0001 



picture will be opened in Internet Explorer or the Microsoft Photo Editor, from which you can 
print. 
 
To see how the molecule packs into the unit cell, pull down the Atoms menu and choose Pack. 
To see the four molecules that constitute the unit cell, use the default X: 0 to 1, Y: 0 to 1, and Z: 
0 to 1 setting. To return to a single molecule, pull down the Atoms menu and choose Trim. To 
see several complete unit cells, pull down the Atoms menu and choose Pack again. This time 
choose X: 0 to 2.0, Y: 0 to 2.0, and Z: 0 to 2.0 
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